Editor completely broke

Since a few days ago the editor has been acting really strange. I first noticed it when starting a new C exercise and noticed that whenever I switched between the header and implementation file, anything I wrote completely disappeared. Since then I have discovered that this also happens when trying to edit exercises I wrote earlier. At one point I was able to edit a solved exercise, but found that instead, the header file had disappeared. All in all, it has become impossible for me to test and submit assignments through the online editor.

Can confirm: This is an issue.

To reproduce: Go to an exercise with multiple files, e.g. https://exercism.org/tracks/cpp/exercises/leap/edit, edit one file, click on the “tab” to edit the other file, click on te first tab, and all changes are gone.

Sorry about this. @dem4ron will fix tomorrow.

1 Like

Thank you, that would be great.
A lot of C and C++ exercises cannot be solved in the online editor while this issue is not fixed.

We pushed a fix for this yesterday, but I just notice now that it didn’t deploy: https://github.com/exercism/website-deployer/actions/runs/6624982389/job/17995038579 :frowning:

I’ll rerun it now.

1 Like

It’s working again. Thanks!

1 Like