Run Vim Test On Local machine

Hello everybody, I’m new on both this site and community. I’m a little stuck with running test for VimScript on my local machine.
The Help file ask me to launch :Vader .vader but it doesn’t work in vim and in the terminal.
I really appreciate any suggestion who can help me.

It is stated that “it doesn’t work” but does it report back anything?

Can you show what you tried, and what happened?

Can you let us know what instructions you followed to install the plugin?

Not a lot of information to go from here, so far.

Have you installed the Vader plugin for tests? We may need to add some instruction to guide, but Preformatted text.

Hello, unfortunately i can’t answer @Smatsher 's question, as i couldn’t get the testing running on my machine either.

@kotp may i point out my status quo and hopefully we’ll be able to catch up with @Smatsher from there?

First of all I followed https://exercism.org/docs/tracks/vimscript/tests

I did so by adding Plug 'junegunn/vader.vim' to .vimrc (located in my $HOME)
and running the : PlugInstall Command
Next i ran $ pip install vim-vint

Now, when it comes down to running tests:
open the exercise

$ vim leap.vim

source the file

:source %

Run the tests

:Vader leap.vader

Leads to the following error:
Error

Here im Stuck, i also tried it with the Test command, added to my .vimrc but that doesn’t work either…
Am I missing a path or something?

Thanks for your help! :slight_smile:

Run the tests:


:Vader <exercise>.vader

Replace <exercise> with your exercise’s name.

this is the HELP.md instruction to run a test, but I don’t know exactly where to get the result I want

sorry i copied that from the doc.
In my program i used it accordingly.

But as far as i understood it we result with the same issue?

I’m trying to install the Vader plugin in vim
and see if the problem is solved

First of all, we must install the plugin for vader in vim
here the link GitHub - junegunn/vader.vim: A simple Vimscript test framework
and you have to add this to your .vimrc file

call plug#begin()
Plug 'junegunn/vader.vim'
Plug 'https://github.com/junegunn/vim-plug.git'
call plug#end()

reload the .vimrc file and open vim
execute this

 :PlugInstall

to run the test follow the HELP.md instruction
which is

$ vim <exercise>.vim

Source the current file to make its global functions available to Vim:

:source %

Run the tests:

:Vader <exercise>.vader

Hope this can help someone who struggle like I did to run this test on my local machine

1 Like

This looks like the Vader plugin was not installed.

Does the Vader tab-complete when you enter that in the command mode (When you press :Va<tab> for example)?

View the terminal playback to see how it should be working once the plugin is installed.

Did you figure out how to run the test on your local machine ?

Thank you Mr kotp. I finally run the test after the installation of the Vader plugin. thanks for your time.

when i type in :Va i can auto complete it to :Vader. :frowning:

Was the exercise file sourced before the Vader attempt?

if i try to source the exercise, i am getting the following error.

This also happens, when i try to source the empty exercise…
But anyways, thats the code i am currently trying to run the tests on:

image