Change the url to get token

I created a PR with the URL that have the api: Fix url to get api by joaothallis · Pull Request #1149 · exercism/cli · GitHub

Would you mind describing why you would want to change the URL?

Looking at the code, the CLI calls SettingsURL with the API base url and appends /my/settings. This produces the following URL:

Your change would instead append /settings/api_cli, which produces the following URL:

When I try both of those URLs, they both seem to actually work (and actually lead to the same API endpoint). I’m not entirely sure it was necessary to change it…