Downloading updated excercise still gets the old version

Hi, in short - when using CLI, I still get old version.

Longer story: I solved some exercises years ago and now I decided to try them once again.

So I just went to one exercise, this time it was Exercism accepted that there is a new solution, clicked that I agree.

When I tried to download that via exercism download --exercise=gigasecond --track=rust, I still got the old version.

I tried to delete my iteration, but nothing changed.

Current state:

How do I know that I get old version?

The downloaded source code contains “module” chrono, but obviously Community solutions contain PrimitiveDateTime as is written in Instructions.

Btw. also web editor shows old version.

How to download that updated exercise via cmd line?

Web editor:

If you submitted the test files in the past, you’ll not be able to receive newer versions. I don’t know if there’s anything the staff can do about it. If you need to, grab files from the github repo:

1 Like

If I take it from repository, after solving the problem, should I then just submit it via cli?

1 Like

That should work… if you already did the download command to get a new copy of the other meta files.

Looks like this as it’s complaining about some metadata.

C:\dev\Exercism\workspace\rust\gigasecond>exercism submit src/ Cargo.toml

    The exercise you are submitting doesn't have the necessary metadata.
    Please see for instructions on how to fix it.

When I copied .exercism directory from the old solution to the new one, I was able to submit the solution.

You’ll need to

  1. make a copy of your changes
  2. exercism download --force -t rust -e gigasecond
  3. restore your changes
  4. exercism submit