Email confirmation not received for changing email address on forum account

I’ve tried to update my forum account email address to one that I currently have access to, so that I can receive email notifications.

I’ve entered my new email adress on the account preferences email change form, and saw the message telling me that a confirmation email has been sent. However, I haven’t received the confirmation email.

How long does it usually take for confirmation emails to arrive? The UI messages shown suggest that any emails should have arrived in my inbox by now.

Troubleshooting attempted so far

  • I’ve double-checked that I spelt my email correctly.
  • I’ve attempted the same with a different email, but haven’t received any confirmation emails yet.
  • I’ve also tried clicking the “resend confirmation email” link, which changed to “sending…”, and then changed to “email sent” - but I still haven’t received any emails at either email address.

Exercism has had issues with their email provider this past week which could be why. I’m sure @iHiD could give you a more concrete answer.

Yes. Forum emails are currently disabled after we got attacked and ended up spending 1M spam emails. It’s not been a fun week on the email front. I’ll fix this in the next day or so, but I think it involves taking the forum offline (it’s a config file read on boot I think), so I want to make sure I don’t totally trash everything as I do it.

Thanks for the reminder and the troubleshooting attempts. I’d actually totally forgotten I need to fix the forum stuff (I set up the “proper” Exercism emails today).

1 Like

Understood, thank you both for your help, and for taking the time to share details about the current situation. :slightly_smiling_face:

Please don’t prioritise or rush anything on my behalf, my email updates are completely non-urgent.

Sorry to hear about the attack and the pain it has caused, I hope it hasn’t been too tough a week. :orange_heart:


Just to remind the team about a similar issue I had which never got a reply.

You should be able to rerequest this now and it should work.

@safwansamsudeen Your issue is unrelated to the forum so not affected by this. But thanks for alerting me :slight_smile:

1 Like

It worked for me, thank you! :slightly_smiling_face:

1 Like

Great. Thanks! :)