Fatal Error while solving Hello, World!

Hello. I’m trying to solve the Hello, World! exercise but I keep running into a fatal error. When I try to compile, it says ‘DUnitX.Loggers.Console’ not found. My frustration is growing with this…

What track/language? Could you share your code? There should be no Console involved in the exercise.

I’m using Delphi. Pascal.

I deleted the program because everything was nonsensical. I would rather just use Exercism’s code editor but now I can’t figure out how to switch back… I don’t know what to do.

It’s hard for us to provide guidance without seeing your code.

You can click the ... in the top-right of the exercise and reset the exercise. You can then start over, and either work locally or work via the web UI.

Here’s a screenshot of what it looks like after I run it.

  1. Images are hard to read. Please use text to share text.
  2. That program looks very very different from the stub code (what you see when you reset the exercise). The expected solution is supposed to be very similar to the stub. The program you’re writing and the code you need to write to solve the exercise are very different. You may want to (1) watch the intro video on the Hello World page then (2) reset the code and solve the exercise using the pattern found in the stub.

The program I’m using is Delphi 11.3. I’m trying to figure out how to go backwards and not use my own local machine. I can’t figure out how to back track.

@IsaacG I was able to solve the issue I was having. I discovered that I didn’t add DUnitX to the installation process. So, that solved those issues. However, upon correctly installing Delphi 11 CE I’ve come across yet another problem.

[dcc32 Fatal Error] DUnitX.ConsoleWriter.Base.pas(244): F2039 Could not create output file ‘C:\Program Files (x86)\Embarcadero\Studio\22.0\source\DunitX\DUnitX.ConsoleWriter.Base.dcu’

This is the syntax that I get when I try to run the test project Hello World

I’ve never written a line of Delphi in my life :blush:

It might be good adding that DUnitX to the track docs, if it’s not already there. For the latest error, I workse start by checking if that directory, C:\Program Files (x86)\Embarcadero\Studio\22.0\source\DunitX exists or not, and creating it if not. Then figuring out why it’s trying to write to that path. That doesn’t look like it should be part of your workspace area, so I’m not sure why it would write there.

Ah, I see. Well, I’m just an 1/8 inch higher level than a first timer. So, most of this seems like rocket science to me. I’m not savvy with different component parts and what’s needed for specific files to run successfully. Does that make sense?

The directory exists and contains a plethora of additonal DUnitX files. It just doesn’t contain the one it’s erroring on. Do you know where or how I can obtain this missing file?

Well, it looks like I solved yet another problem! The issue this time was invoking the setup wizard. Wow… I hope this thread helps other people.

1 Like