I cannot install CLI using terminal on Mac

When I digit “exercism configure --token=7dede0ac-608a-4967-8a16-xxxxxxxxxxx” in the terminal I have this message:

Error: mkdir /Users/emanuelecorradinoangiletti/.config/exercism: permission denied

It appears that this is trying to create a directory for you, but the directory or a file of that name already exists.

Do you get the same error when running the command as sudo?

I tried already with sudo but pops up the same error

Is User supposed to be capitalized?

Can you run ls -ld on each path component and paste the outputs?

I am having the same issue even if I CD into the .config directly and attempt to use mkdir to make exercise folder I get the permission denied error. I would really like to do the exercises locally on my machine.

What exactly are you typing (please copy/paste). What exactly is the error (please copy/paste). What does pwd output immediately after the error?

i’m getting the following error “zsh: permission denied: exercism”. can someone help me?

1 Like

Conversation forked to a new thread.

1 Like