Improvement of Colors() comment in Resistor Color

I’d like to propose a fix in Resistor Color exercise in Go track. The comment above Colors() function says
// Colors should return the list of all colors.
It suggests that the function SHOULD, but don’t HAVE TO return the list of all colors.

Meanwhile, the second function has more suitable comment that says
// ColorCode returns the resistance value of the given color.

In my opinion, the fix is more about having both comments in the same tone, rather than about saying one of either is wrong.
If you see this as an issue as well, I would be happy to fix that.

I’m happy for you to make this change. Thanks for opening a forum post before doing it :slight_smile:

Note: If this PR has been pre-approved, please link back to this PR on the forum thread and a maintainer or staff member will reopen it.

Thanks. If @junedev or @andrerfcsantos approve this, then you could also update other exercises where this is the case. A quick search suggests there are quite a few places: