[Improvement] Queen Attack test names are incorrect

In the Queen Attack problem specification, tests for row/column less than 0 state that row/column must be positive. However, 0 is not positive so the test names and error strings don’t match the expected behavior.

Maybe we should rephrase to something like “must not be negative”?

That was my thought. Any issue with me raising a PR with that change?

Changing the message has the potential to impact generated tests which would break solutions. I’m not sure it’s worth changing.

We could just have new test cases that reimplement the old ones.

1 Like