Minesweeper 48in24 Exercise

Hello, and thank you for the Pharo Exercism track.

I’ve been trying to complete the Minesweeper challenge as part of the 48in24 this week.

I’m doing the code using the online editor and no matter what I enter I get “An error occurred while running your tests.” I’ve tried to add syntax errors to get a compiler error or any other message than “An error occurred”. I’ve done a few other Pharo Exercises and those have all worked. Currently the code I have is completely blank and I still get “An error occurred”.

I did the same for “Raindrops” and the error is " We received the following error when we ran your code:
Invalid source code - Can’t parse type.
So it’s at least telling me there is something going on with a blank file.

I’m not sure what I need to do to go past this.
Thanks for looking into it.

Same thing here. No test results, no failure explanation.

I was also able to find my way through the (very confusing) Pharo IDE and submit a solution from it that was passing all 12 test cases locally but it still failed on Exercism website.

Thank’s for a wonderful site! It is thrilling to participate in the 48in24 exercises each week!

But I am stuck with the Minesweeper exercise in the Pharo track. Whatever I put into the online code editor, my full solution, a simple one only returning an empty result, ends up with a generic “Timed out” error without any specific details.

Other Pharo exercises seem to work correctly when testing.

Please have a look at this!

1 Like

@Bajger any idea?

@AndrasLengyel, @GabrielErbetta Hi! This is strange, I’ve got error timeout on my solution, when running tests in Online editor. I will debug with test runner and let you know guys!


Hi again! Found a race condition in test runner method, will submit PR soon!


@GabrielErbetta @AndrasLengyel Minesweeper should be operational now! Sorry for the trouble and thanks for reporting!


Hi @Bajger,

It works much better now! Minesweeper now operating within normal parameters. :slight_smile:

Thank’s for a good and quick fix!

1 Like

Don’t be sorry @Bajger , you did great.
It worked flawlessly now, thank you.