Nim test runner bug after exercism submit

I’m recently getting AN ERROR OCCURRED on the exercism website after running exercism submit .... Here is a screenshot:

Here is the traceback:

We received the following error when we ran your code:
tcc: error: libtcc1.a not found
Error: execution of an external program failed: 'tcc -o test_clock  -lm -lm -lrt   -ldl    

I’m getting the same error with the Hello World exercise, so there seems to be something wrong with the Nim environment

Me too. I tried my old correct exercises as well as copy-pasting working community solutions for new exercises and always the same problem.

How strange. Neither the Nim test runner nor the exercsises have changed in a while as far as I can see.

(cc @ErikSchierboom @ee7-1282)

Actually, the nim test runner will have been rebuilt recently due to a docs syncing commit. I’ll try and revert that deployment. I wonder if something in the base image has changed.

@ErikSchierboom - we probably shouldn’t re-build/deploy all our tooling on these changes.

For @ErikSchierboom:

The latest image has shrunk from 11.92mb to 11.74

I’ve retagged the old image as production with:

I ran:

docker tag
docker push

This seems to have fixed it.


I confirm it work for me too. Thank you, @iHiD :slight_smile:


But that shouldn’t necessarily mean that the test runner itself has changed, just that the workflow ran. Looking at the workflow, it does look like the Docker cache was no longer valid, so it would have re-run the commands which could lead to changes. Very weird.

I’ve opened ci: allow running CI workflow manually by ErikSchierboom · Pull Request #164 · exercism/nim-test-runner · GitHub which does indeed show that the test run fails. Thus I’ve opened an issue: Error when running smoke tests · Issue #165 · exercism/nim-test-runner · GitHub

Apologies for the breakage here.

The underlying issue should be resolved by this commit to the exercism/nim-test-runner repo. See the commit message for more details.

The latest nim-test-runner state has been deployed. It should work. Please let me know if you see any further problems.

1 Like