Ruby Test Runner Broken - Chess Game in Ruby (Screenshots Included)

My solution passes all tests just fine when I run it in the CLI with the provided test file.

But when I upload it, I get an error.

I have uploaded three iterations, seeing if it was my fault. I can’t think of anything to do differently.

Any suggestions?

devin@devinsl4:~/Exercism/ruby/chess-game$ ruby chess_game_test.rb
Run options: --seed 23696

# Running:


Finished in 0.002125s, 6588.1671 runs/s, 6588.1671 assertions/s.
14 runs, 14 assertions, 0 failures, 0 errors, 0 skips

I tried submitting two Ruby exercises today (Spiral Matrix, Transpose) and got the same error. My tests also pass in the CLI. Maybe it’s a broader Ruby track issue?

1 Like

Yeah, same thing for Black Jack.

devin@devinsl4:~/Exercism/ruby/blackjack$ ruby blackjack_test.rb
Run options: --seed 29433

# Running:


Finished in 0.005189s, 10791.1181 runs/s, 10791.1181 assertions/s.
56 runs, 56 assertions, 0 failures, 0 errors, 0 skips

We are currently doing some work on the test runner for this track. It may be that, it might be unrelated.

I wanted to thank you for reporting, and that we are now aware of these examples as well.


I’ve reverted recent changes and it now works. Thanks for reporting and sorry for the pain.

1 Like

Unsolicited issue linked to this, not reopened:

Just in case it ends up having traffic on it at some point later.

Should be fixed now.

1 Like

Thank you! Confirming that my tests are now passing after re-submitting these exercises online.

1 Like