Running elm test after following elm track docs has a version deiscrepancy

I get the following after installing elm-test at latest-0.19.1.

This output is from the hello world exercise, if that helps.

$ elm-test

This version of elm-test only supports elm-explorations/test 2.x, but you have "1.2.2".

Hi @razetime indeed elm-test has been updated to the latest version of the elm-explorations/test package couple months ago. We had not needed to update the exercism setup yet but the update for exercism is now done and will likely be merged soon (Update `elm-explorations/test` by jiegillet · Pull Request #551 · exercism/elm · GitHub)

Meanwhile, you can install the version 0.19.1-revision9 of the elm-test cli as explained in its readme GitHub - rtfeldman/node-test-runner: Runs elm-test suites from Node.js. Get it with npm install -g elm-test

Let me know if you figured it out.

1 Like

Hi @razetime, the exercises have been updated on the repo, they should work with the latest elm-test now. You might need to pull the exercises again.


I tried exercism download --exercise=hello-world --track=elm --force, didn’t seem to work for pulling the latest version of it.

However, installing 0.19.1-revision9 of elm-test works just fine. Thanks a lot.

1 Like

Mmh, I’m not sure why that doesn’t work. I tried it and got the same results as you, but when I deleted the exercise and re-downloaded it, I got the latest version.

For new exercises that you haven’t downloaded already, you will for sure need the latest version of elm-test.

1 Like