Running the dart Hello-World exercise on Windows 10

I have not gone pass the Hello-World exercise in dart, today is the second day.

I have tried the two kinds of installations, watched “Stevinator”, checked Stack Overflow, checked Git…
I need help! It’s really taken my HOURS!

Do you see that the exercism download command says “Downloaded to” a particular directory? You have to cd there first before running dart test

Please Glenn could you please tell me what that means? I’m still learning.

According to the configuration information shown at the top of your screenshot, you have an Exercism directory in your home folder. The exercism command puts exercises that you download under that directory, organized by track.

The process is this:

> exercism download --exercise=hello-world --track=dart
> cd c:\Users\owner\Exercism\dart\hello-world
> # edit the source code
> dart test
> exercism submit

I opened the folder and opened the test file. It automatically opened on my VS code. But after editing the code and ran the dart test on my cmd line, I got this:
C:\Users\owner>dart test
No pubspec.yaml file found - run this command in your project folder.
but here:

You are not in the right directory when running dart test. You are in C:\Users\owner and you should be in C:\Users\owner\Exercism\dart\hello-world

Ok. Let me try again please.

Ok Glenn, I’ve not gotten it right yet. here:

I understand that File Explorer shows the files in the proper directory. That doesn’t matter.

Your cmd window is where the problem exists. You have not changed to the exercise directory. Before you enter the dart test command, you must do this:

cd c:\Users\owner\Exercism\dart\hello-world

OK then. Let me try again please.

Still not there yet, Glenn. I’m on another system and I’m using Powershell. I ran the cd... command but I got this:

PS C:\Users\Ugodiuko\Exercism\dart\hello-world> dart test
dart : The term ‘dart’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • dart test
  •   + CategoryInfo          : ObjectNotFound: (dart:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

PS C:\Users\Ugodiuko\Exercism\dart\hello-world>

On this other system, you need to install Dart

Oho! Right away!

Oh my Jesus!!!
Glenn it worked!
With the first system! Oh what needless pain we bear!

Screenshot (34)
Thank you very much Glenn for your time, I appreciate it!

You will want to reset your token, even though it is attempted to be obfuscated here.

Just an FYI.