Some exercises for a concept remain locked after the learning exercise has been solved

In the Python Syllabus, I currently have two concepts where apparently I cannot unlock all of the exercises. This may well be due to my inability to find the right button or trigger for doing so, or it may be unintended behaviour of the software.

One example is the “String Methods” concept. I’ve solved the learning exercise, “Little Sister’s Essay”. The other solved exercise, “RNA Transcription” I had already done ~3 years ago. The remaining two are locked. The “Lists” concept is in a similar state, as you can see from the following snapshot of the overview graph:

In case I am doing something wrong, could you please point out to me where I would have found instructions on how to unlock the remaining exercises? Thanks a lot in advance for your help!

Hi, those exercises require multiple concepts to be unlocked. Say there is an exercise that has concept lists and dictionaries. It will show up as an exercise for both lists and dictionaries meaning you will have to have solved both of the concept exercises before being able to do the exercise.

The reason is that the student shouldn’t do exercises which has not already been covered in the syllabus.

Did some more reaserch. Yes this isn’t that clear. I will bring this up later with the correct people.

Although if we go into the github we will see and I guess you haven’t done loops yet:
Which is located here:

It isn’t super easy to tell how this path goes unfortunately without going through the file on github, although it is no bug.
To unlock the rest you will have to do more concept exercises.

That is perfectly fine, and thank you very much for taking the time to find out for me. Much appreciated!

1 Like