Stuck - Automated tests failing, but local passing

Hi, there, embarrassing I know, but I’m stuck on exercise 1 ‘Hello, world!’. The test pass fine locally have been failing to pass exercisms automated tests. Any idea how I can proceed?


Welcome @MrBadger :wave: thanks for posting!

Could you please post the code you are submitting so we can take a look at it? You can create a code block by using triple backticks and the name of the language like this:


<code here>```

I just tried Hello World for ReasonML on the site, and while the tests were extremely slow, they did run and my solution passed. So I am not entirely sure what is going on in your situation, but am happy to help where I can. :grinning:

Hi BethanyG, thanks for much for responding!

ok here’s the code…

let hello = () => "Hello, World!";

so .when I first submitted this it showed a pass, but I only notice the failed today, over a week later when i went to move to next exercise. Hearing you’ve submitted successfully, I tried again, and it came up passed, but, then switched to failed. not sure if thats relevant or helpful to know.

thanks again

@MrBadger – you have the same solution I do. Did you upload that via the CLI or cut-and-paste it into the online editor? The difference being that I typed directly into the online editor, but you’ve been uploading via the CLI submit command.

We have recently had a string of issues (an example here) with solutions uploaded via the CLI passing and then reverting to failing.

I recommend cutting and pasting the solution into the online editor and then running the tests from there to get around the blockage while we try and track down what is happening.

@iHiD & @ErikSchierboom – this is another scenario where uploaded solutions pass and then somehow fail again.

Updated to Add Submitted the same solution I had typed online via the CLI as iteration two. It failed.

Thanks for all of that.

I see you’ve prompted some for help, so thanks for that.

So, yes I used CLI, however I’ve just tried using the editor, and ‘Run tests’ which is needed before ‘Submit’. The ‘Run tests’ are timing out.

Hey BethanyG, do you have the power to unlock the next exercise so i can move on in the meantime?


Sadly, I don’t have the power to do that. One thing to try is to leave the track, and then sign back up to it. That will reset your progress. Then, type the hello world answer into the online editor and see if that will get the tests to run.

I will also take a look with a folllow-on exercise to see if the runner has just failed, or we’re in some other odd state with things.

Clearly there is an issue with the way the test runner is evaluating things - we just haven’t tracked it down yet – so apologies for that, and thank you for your patience. :slight_smile:

No worries, thanks anyway. I’ll try that and check back periodicially. Thanks all for your efforts.

I just tried the Leap exercise online and got repeated timeouts despite a correct solution. So I think the online runner is now in a state where it is unhappy, and will need some TLC. Someone will update here once we get it sorted.

Thank you for being such a good sport about it - hopefully, we’ll get it address soon.

Hi Bethany, Just curious if you know if there’s any progress on resolving the test runners’ tendency to time out? (or, if there’s likely to be?)


Dunno if it this is helpful or I was just doing it wrong before, but my local tests were passing while the “submit” was failing when pushing the “.re” file up alone. I switched to exercism submit src/* to push all files in the src directory and twice the tests passed without issue.

awesome, thanks. I just tested and they didn’t time out this time, so I guess its been fixed! Thanks!