Swift test broken?

I just completed the ListOps exersise in swift. All tests pass on my powershell. I submitted the code and it fails. I tried twice. Can someone check and see what is going on. I can send a capture of all the tests passing on my system if need be.

What’s the test output on the website? “Failed” is pretty generic.

It says something like bip bop boop. can’t understand . That is why this is wierd. It is not a swift error.

Unless it says literally “something like bip bop boop. can’t understand”, it would be helpful if you could copy/paste the exact error message. “something like bip bop boop” is pretty useless for debugging anything.

First yes that is almost exactly what it says. I will go copy it but before I do. I just ran the tests in the editor on here. It passed all 20 but does not give me a ssubmit button. It is greyed out. Now while that is being chewed on I will go copy the exact faiil.

Beep boop bob a hop, could not compute…

In order for our systems to analyze your code, the tests must be passing.

Interested in improving Exercism’s automated tooling? We need your help.

That is what I get no errors nothing. When I run the tests on the web site it passes all 20 and does not give me the submit button.

If the buttons are grayed out but the tests are passing, you can try adding a space to your code somewhere. That should allow you to rerun the tests. When the tests pass, the submit button should become active.

If the tests all completed successfully and the submit button is not working, it might be helpful to share a screenshot.

This suggests the message is coming from the analysis step, not the test runner. When you run tests, Exercism runs two separate steps: (1) run the test and (2) if the tests pass, run the analysis tool which provides automated suggestions/feedback.

If the analysis tool is telling you the tests are not passing, either a test is actually failing or, if all the tests are, in fact, passing, something may be broken in the test runner or analysis runner. A screenshot may be helpful here.

The “Beep boop bob a hop” message comes from this code here which is triggered on iteration.status == IterationStatus.TESTS_FAILED. The system has the iteration status set to FAILED for some reason.

Ok I did as you said and put a space. Let me say before I paste the result. My code doesn’t seem wrong and it does not seem to run slow on my computer. I have run the tests many times.
Here is what the web says

Your tests timed out. This might mean that there was an issue in our infrastructure, but more likely it suggests that your code is running slowly. Is there an infinite loop or something similar?

Please check your code, and if nothing seems to be wrong, try running the tests again.

I also will mention all the tests passed the first time I pushed run on the web but like I said I never got a submit button.

I have done 30 different languages this same way on exercism and this is the first one to give me problems.

Unfortunetly I have to get to bed it is almost 1 AM here and I get up at 6. I will be back then. Hopefully things will work then.

If it still doesn’t work, please send the code used and I can investigate.

It looks like this was fixed over night. It seems something was changed on the web where now it is waiting 10 seconds. What I have found on my computer is the first swift compile can take a few seconds maybe that was causing the problem. Everything seems to be working now withno code change from me. Thanks to who ever fixed it and what ever the problem was.