Testimonial notification not being shown

Mentees are giving me testimonials but the smiley face notification in the navbar isn’t coming. Has been happening for a few days.

Is anyone else facing this problem?

Hah! I didn’t even notice I had unread testimonials.

@iHiD responded on discord that this was likely due to some recent PRs. He reported the morning of 6/6 that he thought it was fixed, but either it wasn’t or it now fails in the opposite way. I’d link to the discord thread but I’m on my phone where I use the app and don’t see a way to get a link.

If you long click a (regular) message, the pop up message has a "Copy message link* option.

Message link in Discord

I only got a “Jump” icon, but I think that’s because the message I long-pressed itself had a link in it.

Anyway here it is:

To clarify, is it now stuck on, off, or both?

As of yesterday, it was stuck off for me.

I can’t reproduce locally, which means it’s probably a race-condition in production, so I’ve added locks and will deploy if it goes green.

PR here: Use lock for cache updates by iHiD · Pull Request #5554 · exercism/website · GitHub

There’s a bit commented out above those LOCs which are what I really want, but our MySQL version doesn’t support it, so instead it’s a little horrible atm.

User::Data.where(id: user.data.id).update_all(
  cache: Arel.sql(%{
      COALESCE(`cache`, "{}"),
      '{"#{key}": #{new_value}}'

Mine is still stuck to “on”.

I just received a testimonial that I was not notified about.

I think I was notifed about my previous received testimonial. This was 5 or 6 days ago: the notifications list and the testimonial itself say 6, but the testimonials list says 5.

@iHiD to update: I’m still not receiving the notifications.

Same here. I have bunches of unread testimonials and haven’t seen any notificiations.

This should fix it: Fix bug in resetting cache by iHiD · Pull Request #5601 · exercism/website · GitHub


Woo! I have the notification now. Thanks!

Great. I’ve not deployed it yet, but manually tried it for you :slight_smile:

OK, small chance this is now fixed!

The current state might be wrong, but the next transition should succeed correctly.

1 Like

Mine is now correctly off for the first time in a while. So it seems fixed, but now I miss the red dot. :smiling_face_with_tear:

1 Like

The fix was successful, by the way.

1 Like

Unfortunately, I’m yet to test it :cry: - but thanks for the fix.

1 Like