Unable to install exercism-v3.1.0 on Ubuntu ARM x64


I’ve tried to follow the installation guide but I get an error when executing:


Error: Exec format error

I’ve tried the different arm x64 versions for Linux:

uname -m: “aarch64”

I run a virtual Ubuntu (22.10, arm, x64) on an M1 mac.

Best regards

What does the command file ~/bin/exercism report?

Thank you for your response :slight_smile:

The command returns:
/home/ubuntu/bin/exercism: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), statically linked, Go BuildID=rg1nzPJeTBWDjkfJENP-/Ya8ZSQESpm7IRezbvN9w/BenFsQkcIpEeBZcg40z-/YdxIC5hXlgRF95Ox9VZV, stripped

So it seems that I have downloaded the wrong architecture.

I have downloaded the files:

And when I unpack them, both are for 32-bit architecture.

It seems that there are no app available for Ubuntu x64 on arm?

Best regards

I have no clue. I didn’t build any of the executables. It’s possible all the Arm builds are x32. You can always install Go and build it from the source code on GitHub.

Thanks! I might give that a try :)